Suggested Web Technologies Stack

We suggest that you use the following set of web technologies in development. Installation instructions are provided below.

Technologies That Require Installation

The technologies that require installation in this class are Git, NodeJS, and Express. We require you to have the most updated version of NodeJS (at least version 8.9.4). Links to installing them for Windows, Mac, and Ubuntu are provided below.

Technologies That Don't Require Installation